Notifi Alerts Delayed

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved, and alerts are functioning as normal.
Posted Mar 15, 2023 - 16:15 EDT

Investigating

Notifi Alerts may be delayed. As a result, users may be intermittently unable to receive notification alerts including notifications for transactions and security.

Support teams are engaged and working to restore service as quickly as possible.
Posted Mar 15, 2023 - 10:32 EDT
This incident affected: Personal Services (Personal Online Banking) and Business Services (Business Online Banking).