Personal Mobile Banking - Intermittent Access
Incident Report for Hingham Institution for Savings
Resolved
Service to our Personal Mobile Banking application has been restored.
Posted Jul 16, 2024 - 12:55 EDT
Investigating
We are currently researching an issue that is resulting in intermittent availability for users attempting to access our Personal Mobile Banking app. While we work to restore service, users can continue to access their account information through Personal Online from our website at www.hinghamsavings.com.
Posted Jul 16, 2024 - 11:59 EDT
This incident affected: Personal Services (Personal Mobile App).