Personal and Business Online Banking Outage
Incident Report for Hingham Institution for Savings
Resolved
We have restored all of our digital services and we are monitoring performance. We appreciate your patience and apologize for the inconvenience. Happy Thanksgiving!
Posted Nov 28, 2019 - 09:34 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 28, 2019 - 08:37 EST
Update
We continue working to restore access to personal and online banking applications. Our primary third-party data center in the Midwest was impacted by a significant weather-related power outage and restoration of services overnight has taken longer than expected. We apologize for the inconvenience and appreciate your patience.
Posted Nov 28, 2019 - 08:14 EST
Update
We have made progress on restoring online access, thank you for your patience.
Posted Nov 28, 2019 - 08:06 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 28, 2019 - 06:58 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 28, 2019 - 05:57 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 27, 2019 - 22:43 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 27, 2019 - 21:25 EST
Update
We have identified the underlying problem at one of our primary data centers and we are implementing a fix.
Posted Nov 27, 2019 - 20:35 EST
Identified
We are currently experiencing an outage impacting both our personal and business online banking services, including both of our mobile apps. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Nov 27, 2019 - 20:21 EST
This incident affected: Personal Online Banking, Business Online Banking, Personal Mobile App, Business Mobile App, Desktop Remote Deposit Capture, ACH/Wire Transfer Services, Bill Pay Services, Electronic Statements, HIFS Mastercard Debit Cards, and Online New Accounts.