Personal Online and Mobile Banking Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Sep 06, 2025 - 09:49 EDT

Investigating

We are currently experiencing an issue that may cause some users to receive an error message when accessing our Personal Online or Mobile Banking App. We apologize for any inconvenience and are working to restore service as quickly as possible.
Posted Sep 06, 2025 - 08:35 EDT
This incident affected: Personal Services (Personal Mobile App).