Debit Card Transaction Processing Interruption
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 15:06 EDT
Update
We are continuing to investigate this issue.
Posted Mar 27, 2024 - 14:11 EDT
Investigating
We are aware of an issue impacting our Hingham Savings Debit Cards that may cause some transactions to be declined in error and spending limits to be reduced to $500 for purchases and $200 for withdrawals at an ATM machine. We are working to restore service as quickly as possible and apologize for the inconvenience.
Posted Mar 27, 2024 - 13:07 EDT
This incident affected: Personal Services (HIFS Mastercard Debit Cards).