Personal and Business Mobile and Remote Deposits
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 15:27 EDT
Update
We are continuing to investigate this issue.
Posted Sep 15, 2022 - 12:54 EDT
Investigating
We are currently investigating an issue with the mobile deposits service in our Personal and Business mobile banking apps as well as the remote deposit capture service available through Business Online. We are working to restore service as quickly as possible and apologize for the inconvenience
Posted Sep 15, 2022 - 12:35 EDT
This incident affected: Personal Services (Personal Mobile App) and Business Services (Business Mobile App, Desktop Remote Deposit Capture).