Personal and Business Mobile Apps
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 18:34 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 03, 2020 - 18:34 EDT
Identified
We are experiencing an issue with our Personal and Business Mobile Apps. Our online banking service is available in the meantime. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Sep 03, 2020 - 17:47 EDT
This incident affected: Business Services (Business Mobile App) and Personal Services (Personal Mobile App).