Personal and Business Mobile App
Incident Report for Hingham Institution for Savings
Resolved
Functionality has been restored to our Personal and Business Mobile Apps.
Posted Feb 21, 2021 - 09:14 EST
Monitoring
We have identified the cause of the issue impacting our Personal and Business Mobile Apps and have restored functionality. We continue to monitor both our Personal and Business Apps. Thank you for your patience.
Posted Feb 21, 2021 - 08:23 EST
Investigating
We are experiencing an issue with our Personal and Business Mobile Apps. Our online banking service is available in the meantime. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Feb 21, 2021 - 07:36 EST
This incident affected: Personal Services (Personal Mobile App) and Business Services (Business Mobile App).