Automatic Sweep Outage
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 21:01 EDT
Identified
We continue to work to resolve this issue.
Posted Mar 15, 2024 - 13:47 EDT
Investigating
We're aware of an issue causing a small number of customers with automatic transfers between accounts to see incorrect balance information. This may affect your ability to use your debit card, make online wire and ACH transfers.
We sincerely apologize for any inconvenience. We've identified the cause and are working hard to fix it as soon as possible.
In the meantime, if you're experiencing this issue, please contact us directly at 781-749-2200 and we can help you complete your transaction.
Posted Mar 15, 2024 - 12:27 EDT
This incident affected: Personal Services (Personal Online Banking) and Business Services (Business Online Banking).