Electronic Statements - Intermittent Outage
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Nov 04, 2019 - 15:48 EST
Investigating
We are aware that some users may be unable to access electronic statements and are working to identify the underlying root cause of the issue. This issue appears to be intermittent and does not appear to be impacting all of our users.
Posted Nov 04, 2019 - 12:12 EST
This incident affected: Personal Services (Electronic Statements).