Hull Branch Temporarily Closed
Incident Report for Hingham Institution for Savings
Resolved
Power has been restored, the Hull branch is now open.
Posted Mar 24, 2020 - 11:50 EDT
Investigating
Due to a power outage in the Town of Hull the Hull branch is currently closed. All other branch locations as well as our ATM network, online and mobile banking are operating as usual.
Posted Mar 24, 2020 - 08:58 EDT
This incident affected: Branch Service.