Website Service Request Forms
Incident Report for Hingham Institution for Savings
Resolved
We are pleased to announce that the issue preventing customers from accessing our website service request forms has been resolved.

You can now submit your service requests as normal.

Thank you for your patience and understanding.
Posted Aug 01, 2024 - 11:14 EDT
Investigating
We are currently investigating an issue that is preventing customers from accessing our website service request forms. We understand the importance of being able to submit requests easily, and we apologize for any inconvenience this may cause.

You can reach our Customer Experience Team via email at cs@hinghamsavings.com or by phone at 781-749-2200 and our team will be happy to assist you. We will continue to update this page as soon as the issue is resolved.
Posted Aug 01, 2024 - 10:33 EDT
This incident affected: Website (Website Service Request Forms).