Personal and Business Online Banking
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted May 02, 2021 - 08:33 EDT
Investigating
We are currently experiencing an outage with our Personal and Business Online Banking services, including our mobile apps. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted May 02, 2021 - 08:21 EDT
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App) and Business Services (Business Online Banking, Business Mobile App).