Hingham Savings Debit Cards
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 11:26 EST
Monitoring
The issue impacting our Hingham Savings Debit Cards has been resolved, however we continue experience intermittent access to our HIFS Cards App accessible through Personal Mobile. We appreciate your patience while we work to restore service and apologize for any inconvenience this issue has caused.
Posted Feb 17, 2021 - 09:17 EST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2021 - 08:38 EST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2021 - 07:17 EST
Investigating
We are aware of an issue impacting our Hingham Savings Debit Cards that may cause some transactions to be declined in error and spending limits to be reduced to $500 for purchases and $200 for withdrawals at an ATM machine. Our HIFS My Cards app may also be intermittently available during this time. We are working to resolve these issues as quickly as possible and apologize for any inconvenience this issue has caused.
Posted Feb 17, 2021 - 07:16 EST
This incident affected: Personal Services (HIFS Mastercard Debit Cards, HIFS My Card App).