Debit Card Outage
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 11:06 EST
Investigating
We are experiencing issues impacting our automated phone systems for debit card activation, reporting cards lost or stolen and reporting debit card fraud. While we work to restore service, please contact our Customer Support Team at 781.749.2200 for assistance. We thank you for your patience and apologize for any inconvenience this issue has caused.
Posted Nov 16, 2022 - 09:55 EST
This incident affected: Personal Services (HIFS Mastercard Debit Cards).