Online Mortgage Applications Unavailable
Incident Report for Hingham Institution for Savings
Resolved
As of this morning, our online mortgage application software has been restored to full functionality. According to our third-party provider, there is no evidence that this incident resulted in the exposure of any customer data. Thank you for your patience during this outage.
Posted Mar 23, 2020 - 09:21 EDT
Monitoring
Our third-party service provider for online mortgage applications, Finastra, has now publicly announced that it suffered a suspected ransomware attack early on Friday, 20 March, and as part of its immediate response, shut down all of its data centers to contain the threat. Finastra has also indicated that it has no evidence that any customer data was accessed or exfiltrated as part of the attack. Finastra is in the process of bringing its systems back online and we will continue to monitor its progress. We apologize for the inconvenience and we encourage you to contact any of our residential mortgage lenders directly for assistance.
Posted Mar 21, 2020 - 13:21 EDT
Identified
We believe our third-party service provider has identified the cause of the ongoing disruption to our online mortgage application service. Although we do not have an estimated time for restoration of the service, we do not believe we will restore service today. We apologize for the inconvenience and we encourage you to contact any of our residential mortgage lenders directly for assistance.
Posted Mar 20, 2020 - 13:51 EDT
Update
We continue to investigate this issue with our third-party service provider and we believe we understand the nature of the issue. We currently do not have an estimated time for restoration of service.
Posted Mar 20, 2020 - 11:58 EDT
Investigating
We are currently investigating an issue impacting the availability of our online mortgage application software. Thank you for your patience as we work to restore service.
Posted Mar 20, 2020 - 09:53 EDT
This incident affected: Personal Services (Online Mortgage Applications).