Online Account Opening - New Accounts
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted 10 days ago. Sep 05, 2019 - 10:26 EDT
Identified
We have identified an issue with our online account opening service resulting in an error message when accessed from our website or through online and mobile banking. We are working to restore service as quickly as possible and apologize for the inconvenience. For immediate needs, please contact Client Services at 781.783.1796.
Posted 10 days ago. Sep 05, 2019 - 09:59 EDT
This incident affected: Online New Accounts.