Winter Storm - Branch Closing

Incident Report for Hingham Institution for Savings

Resolved

All branch locations have resumed normal business hours.
Posted Feb 25, 2026 - 08:24 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 24, 2026 - 08:22 EST

Monitoring

Due to the continued impact of the winter storm, all branch locations will remain closed today, Tuesday, February 24.

All other operations—including customer support and payment services—will continue during regular business hours. For your convenience, Online Banking and Mobile Deposit remain available 24/7.
Posted Feb 21, 2026 - 16:56 EST
This incident affected: Locations (Branch Locations).