Wire Processing Delays

Incident Report for Hingham Institution for Savings

Resolved

Service Update: Wire Transfers Restored The processing delay for incoming and outgoing wire transfers has been resolved. Systems are now fully operational, and standard processing times have resumed. Thank you for your patience.
Posted Jan 22, 2026 - 10:41 EST

Investigating

We are experiencing processing delays for incoming and outgoing wire transfers. While we continue to process incoming and outgoing domestic wires, processing times are extended and may take longer than normal. We are working to restore service as quickly as possible and apologize for any inconvenience this issue may cause. To inquire about the status of an outgoing wire, please contact us at 781.749.2200.
Posted Jan 22, 2026 - 09:51 EST
This incident affected: Business Services (Business Online Banking, Business Mobile App, ACH/Wire Transfer Services).