Business Online - ZEscrow
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 14:03 EST
Identified
We are experiencing an issue with our Business Online Clients accessing ZEscrow. We are working with our partners to restore access as quickly as possible and apologize for the inconvenience.
Posted Mar 07, 2024 - 13:41 EST
This incident affected: Business Services (Business Online Banking).