Business Online International - Intermittent Outage
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 12:03 EDT
Investigating
We are experiencing an issue within Business Online Banking with our Wire Transfer service that may prevent users from being able to process foreign wires only. Customers may experience an error message when submitting a foreign wire transfer. If you need to process a foreign wire, please contact our Cash Management Team at 781-783-1701 for assistance.
Posted Sep 15, 2021 - 11:21 EDT
This incident affected: Business Services (ACH/Wire Transfer Services).