Intermittent Login Issues
Incident Report for Hingham Institution for Savings
Resolved
We have restored Business Online Banking functionality. We appreciate your patience and apologize for the inconvenience.
Posted Nov 29, 2019 - 13:18 EST
Update
We continue to monitor our Business Online banking for connectivity issues.
Posted Nov 29, 2019 - 12:41 EST
Update
We are continuing to investigate this issue.
Posted Nov 29, 2019 - 11:55 EST
Investigating
We are currently experiencing intermittent issues with Business Online Banking. We are working to restore full service as quickly as possible and apologize for the inconvenience. Our Business Mobile App remains available in the meantime. If you should need assistance please contact us at 781-749-2200 or at cs@hinghamsavings.com.
Posted Nov 29, 2019 - 11:20 EST
This incident affected: Business Online Banking.