Personal and/ or Business Online Banking Interruption
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 06:46 EDT
Update
We have restored access to all online banking applications. Thank you for your patience.
Posted Apr 22, 2021 - 06:45 EDT
Identified
We are currently experiencing an outage with our Personal and Business Online Banking services, including our mobile apps. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Apr 22, 2021 - 06:13 EDT
This incident affected: Business Services (Business Online Banking, Business Mobile App) and Personal Services (Personal Online Banking, Personal Mobile App).