Personal and Business Mobile App
Incident Report for Hingham Institution for Savings
Resolved
Functionality has been restored to our Personal and Business mobile banking applications.
Posted Jun 14, 2018 - 13:06 EDT
Investigating
We are experiencing an issue with our Personal and Business mobile banking applications. While we work to restore service, please visit our website at www.hinghamsavings.com to access our Personal or Business online banking.
Posted Jun 14, 2018 - 08:11 EDT
This incident affected: Business Services (Business Mobile App) and Personal Services (Personal Mobile App).