Online Account Opening - Degraded Performance
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 06, 2019 - 15:31 EDT
Investigating
We are currently investigating degraded performance for our ACH network interface for the funding of new accounts opened online.
Posted about 1 month ago. Aug 06, 2019 - 09:25 EDT
This incident affected: Online New Accounts.