Bill Payment for Personal Online Banking
Incident Report for Hingham Institution for Savings
Resolved
Functionality has been restored to the bill payment feature available through our Personal Online Banking service.
Posted Nov 13, 2017 - 14:57 EST
Investigating
The bill payment feature available through our Personal Online Banking service is currently unavailable. While we work to restore service, payments may be scheduled using our Personal Mobile Banking App.
Posted Nov 13, 2017 - 11:47 EST