Branch - Modified Hours and Drive Up Only Locations
Incident Report for Hingham Institution for Savings
Update
We are continuing to monitor for any further issues.
Posted Apr 02, 2020 - 13:00 EDT
Monitoring
Hingham's branch locations are operating on modified business hours. We continue to balance our commitment to serve you with our commitment to your safety and that of our staff. As we modify our branch hours in response to ongoing events, we will also update our Status Page here. All of our online services remain available, as well as our drive-up facilities at these branches.

Branch Hours as of Wednesday, 1 April

Main Office: Open for Regular Business Hours

Main Office Drive Up: Open Monday - Friday 8:30am - 5:00pm, Saturday Open for Regular Business Hours

Hull: Drive Up Only, Open Monday - Friday, 8:30am - 5:00pm, Saturday 8:30am - 1:00pm

Cohasset: Open for Regular Business Hours

Norwell: Drive Up Only, Open for Regular Business Hours

South Hingham: Drive Up Only, Open for Regular Business Hours

Linden Ponds: Open by Appointment Only

Beacon Hill: Open Monday - Friday 10:00am - 4:00pm, Temporarily Closed on Saturdays

South End: Open Monday - Friday 9:00am - 5:00pm, Saturday Open for Regular Business Hours

Nantucket: Open for Regular Business Hours, Monday Through Friday Only, Closed Saturdays
Posted Mar 26, 2020 - 14:22 EDT
This incident affects: Branch Service.