Personal Online and Mobile Banking
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 19:58 EST
Update
We continue to work with our technology partners to restore access to eStatements services.
Posted Feb 17, 2021 - 17:46 EST
Monitoring
Access has been restored to our Personal Mobile app, including mobile deposit, our HIFS My Card app, external transfers and bill payment services . We continue to work with our technology partners to restore access to eStatements as quickly as possible.
Posted Feb 17, 2021 - 13:26 EST
Update
We continue to experience issues impacting the availability of several of our digital services, but are beginning to seeing some improvements with intermittent access restored to our Personal mobile app and mobile deposit services. We continue to work with our technology partners to restores full access to the impacted services as quickly as possible.
Posted Feb 17, 2021 - 12:16 EST
Investigating
We are currently experiencing issues impacting the availability of several of our digital services. Affected services within our Personal Online Banking and Mobile App include: The inability to access our Personal app and make a mobile deposit, access to external transfers, access our HIFS My Cards app, and access eStatements .

We are working with our technology partners, who have been impacted by Texas's severe winter weather conditions, to restore services as quickly as possible.
Posted Feb 17, 2021 - 11:29 EST
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App, Bill Pay Services, Electronic Statements, HIFS My Card App, Account Transfers).