Personal and Business Online Banking Outage
Incident Report for Hingham Institution for Savings
Resolved
We have restored functionality for all of our digital services. We appreciate your patience and apologize for the inconvenience.
Posted Nov 28, 2019 - 23:41 EST
Update
We are continuing to investigate this issue.
Posted Nov 28, 2019 - 23:16 EST
Investigating
Our digital services - including our personal and business web and mobile applications - are currently unavailable. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Nov 28, 2019 - 21:31 EST
This incident affected: Personal Online Banking, Business Online Banking, Personal Mobile App, Business Mobile App, Desktop Remote Deposit Capture, Bill Pay Services, and Electronic Statements.