External Transfer
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 13:33 EDT
Investigating
We are currently experiencing intermittent issues with External Transfers. We are working to restore full service as quickly as possible and apologize for the inconvenience. In the meantime, if you are currently enrolled, you can access this function through the mobile app. Thank you for your patience.
Posted Mar 17, 2020 - 11:58 EDT
This incident affected: Personal Services (Personal Online Banking).