Personal and Business Online Banking
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted 12 days ago. Dec 04, 2018 - 10:25 EST
Investigating
We are experiencing an issue with our Personal and Business Online Banking services, including our mobile apps. We are working to restore service as quickly as possible and apologize for the inconvenience. For immediate needs, please contact Client Services at 781.749.2200.
Posted 12 days ago. Dec 04, 2018 - 09:56 EST
This incident affected: Personal Online Banking, Business Online Banking, Personal Mobile App, and Business Mobile App.